A Pluckeye Forum

A place for Pluckeye users to chew the cud.

You are not logged in.

Announcement

This is the old forum. The new forum is at https://discourse.pluckeye.net/ .

#1 2017-05-18 19:21:10

condol
Member
Registered: 2017-05-06
Posts: 13

[SOLVED] Allow svg while blocking images in Chrome

Hi!

I have google's images blocked. But as a consequence, I can't even download svg attachments from work emails I get in gmail.

Overall I have these rules that pertain to google stuff (I removed deny image/, and deny :443)

deny webcache.googleusercontent.com image/
deny www.google.com image/
allow https://mail-attachment.googleusercontent.com image/svg+xml

I also tried without the https, and without the 'mail-attachment' part. Also tried to do the allow on google.com

But getting an svg+xml from a link: https://mail-attachment.googleuserconte … hment/u/0/?... (shortened)
is still denied.

What am I doing wrong?

Thanks!

Offline

#2 2017-05-18 21:26:07

jon
Administrator
Registered: 2017-01-10
Posts: 525

Re: [SOLVED] Allow svg while blocking images in Chrome

condol wrote:

deny webcache.googleusercontent.com image/
deny www.google.com image/
allow https://mail-attachment.googleusercontent.com image/svg+xml

But getting an svg+xml from a link: https://mail-attachment.googleuserconte … hment/u/0/?... (shortened)
is still denied.

Works for me.  Here's how I tested:

1. Applied the 3 Pluckeye settings above.

2. Composed a mail to my gmail address in Thunderbird.  Attached p128.svg from http://www.pluckeye.net/p128.svg and sent it.

3. firefox https://mail.google.com/

4. Used mouse to hover over attachment, clicked "Download".

5. Opened downloaded attachment.  I see the Pluckeye logo.

Are you sure the Internet media type of the attachment you are receiving is actually image/svg+xml?

You can verify the Internet media type by using

Pluckeye button > History > click details and/or hover over the relevant blocked resource

Offline

#3 2017-05-19 07:20:39

condol
Member
Registered: 2017-05-06
Posts: 13

Re: [SOLVED] Allow svg while blocking images in Chrome

Hi Jon!

Yes I'm sure about the image format, I ascertained it with the method you described.

Removing those 3 lines makes the file downloadable again. Putting those 3 lines back makes it undownloadable.

I installed firefox now just to test this.
With firefox with those 3 lines, the file WAS downloadable.
I tried removing the allow svg+xml rule and it STILL worked (which is not good)

I even tried adding the deny image/ on everything, and it was still downloadable on firefox.
So even if it did download for me on firefox, I don't think it's due to the allow svg+xml rule.

My version is 0.50.4, btw.

Offline

#4 2017-05-19 13:31:53

jon
Administrator
Registered: 2017-01-10
Posts: 525

Re: [SOLVED] Allow svg while blocking images in Chrome

condol wrote:

I installed firefox now just to test this.

Ah, looks like a Chrome-specific bug.  I'll look into it.

In the meantime, perhaps you could use Firefox.

Offline

#5 2017-08-22 14:00:24

jon
Administrator
Registered: 2017-01-10
Posts: 525

Re: [SOLVED] Allow svg while blocking images in Chrome

jon wrote:

Ah, looks like a Chrome-specific bug.  I'll look into it.

The bug has been fixed, and is awaiting deployment.  The workaround until the fix is available is to use Firefox for svg image support.

Offline

Board footer

Powered by FluxBB